Welcome to Our WirelessAdvisor Community!

You are viewing our forums as a GUEST. Please join us so you can post and view all the pictures.
Registration is easy, fast and FREE!

Porting problems when switching carrier

Discussion in 'GENERAL Wireless Discussion' started by Gregory Lee, Nov 1, 2016.

  1. Gregory Lee

    Gregory Lee New Member

    Joined:
    Nov 1, 2016
    Messages:
    1
    Likes Received:
    0
    Last Fri early morning, I tried to switch cell phone carriers - Walmart's MyFamilyMobile to MintSIM. I went thru the activation process on the MintSIM website to keep my phone number. Both companies are MVNOs using Tmobile towers.
    The following day, cell service from MyFamilyMobile was discontinued, but I was not properly activated on MintSIM so until now, I've not been able to make/receive calls or use data. When I've switched carriers with different companies in the past, the switch was almost instantaneous, taking only a few minutes to activate.

    I've been in touch with MintSIM customer service quite frequently, trying to get an explanation as to why the delay. When I asked for a specific explanation, I was told:

    "Technically speaking its called an Async. So, with your activation -- during the initial port issue that was resolved, the system was completing the process of activation and the "Current Async" is still set on "ActivateSubscriber". Its the final step to programming on the back end for a phone. This is the "hang up" that I mentioned in the chat channel. So, the technical operations team can get the Current Async corrected to allow you make and receive calls, text and data."

    What I'd like to know if this delay is due to any incompetence or inexperience on the part of MintSIM? How common are errors like this? Is there anything I can do to expedite the porting process? It has been frustrating being without a phone line, as people cannot call to leave messages or text me (since Fri).

    Any help would be appreciated. Thanks.
     
  2. KevinJames

    KevinJames WA's 1st retired mod
    Senior Member

    Joined:
    Oct 2, 2001
    Messages:
    4,044
    Likes Received:
    739
    Location:
    Central Valley NorCA
    My Phone:
    Samsung S7-Edge
    Wireless Provider(s):
    AT&T & Verizon
    It sounds like they are giving you the run-around. But just as knee-jerk: Have you tried rebooting your phone? I've had a nearly similar situation in an upgrade. After rebooting, the new phone started acting correctly.
     
  3. palandri

    palandri Former Palm Guy
    Senior Member

    Joined:
    Nov 17, 2009
    Messages:
    1,190
    Likes Received:
    863
    Location:
    Chicago
    My Phone:
    Pixel 4
    Wireless Provider(s):
    Project Fi
    I've never heard of MintSIM before and I don't see an address on their site. They could be a start up out of someone's garage, who knows?
     

Share This Page

Copyright 1997-2020 Wireless Advisor™, LLC. All rights reserved. All registered and unregistered trademarks are the property of their respective holders.
WirelessAdvisor.com is not associated by ownership or membership with any cellular, PCS or wireless service provider companies and is not meant to be an endorsement of any company or service. Some links on these pages may be paid advertising or paid affiliate programs.

Positive SSL
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice